aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/flake.nix
diff options
context:
space:
mode:
authordrduh <github@duh.to>2024-07-08 02:12:58 +0000
committerGitHub <noreply@github.com>2024-07-08 02:12:58 +0000
commita46409e2e8e5e360290a2d720bfc3bc71b76be30 (patch)
tree19ca3639a432ed2e9d3393d3e42eb1e00a8a2b43 /flake.nix
parentMerge pull request #449 from denis-roy/master (diff)
parentflake.lock: Update (diff)
downloadYubiKey-Guide-a46409e2e8e5e360290a2d720bfc3bc71b76be30.tar.gz
Merge pull request #450 from motiejus/nixos-24.05
NixOS: bump to 24.05
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index b526a13..a814b87 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,7 +2,7 @@
description = "A Nix Flake for an xfce-based system with YubiKey setup";
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.11";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
drduhConfig.url = "github:drduh/config";
drduhConfig.flake = false;
};
@@ -129,7 +129,7 @@
enable = true;
virtualHosts."diceware.local" = {
listen = [
- {
+ {
addr = dicewareAddress;
port = dicewarePort;
}
@@ -153,9 +153,12 @@
preferencesStatus = "user";
};
ssh.startAgent = false;
- gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
+ gnupg = {
+ dirmngr.enable = true;
+ agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
};
};
@@ -196,12 +199,12 @@
# Testing
ent
- haskellPackages.hopenpgp-tools
# Password generation tools
diceware
dicewareWebApp
pwgen
+ rng-tools
# Might be useful beyond the scope of the guide
cfssl