aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorMotiejus Jakštys <motiejus@jakstys.lt>2024-07-07 11:18:41 +0300
committerMotiejus Jakštys <motiejus@jakstys.lt>2024-07-07 11:19:21 +0300
commitd7b2a034aac44c83098ee098c1479e75dc0578da (patch)
tree4c1f8c3e020ba37b97c198222461c01f9b389b18 /flake.nix
parentMerge pull request #447 from drduh/wip-30jun24 (diff)
downloadYubiKey-Guide-d7b2a034aac44c83098ee098c1479e75dc0578da.tar.gz
NixOS: bump to 24.05
- remove hopenpgp-tools (as per README) - add dirmgr - add rng-tools
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index b526a13..a814b87 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,7 +2,7 @@
description = "A Nix Flake for an xfce-based system with YubiKey setup";
inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.11";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
drduhConfig.url = "github:drduh/config";
drduhConfig.flake = false;
};
@@ -129,7 +129,7 @@
enable = true;
virtualHosts."diceware.local" = {
listen = [
- {
+ {
addr = dicewareAddress;
port = dicewarePort;
}
@@ -153,9 +153,12 @@
preferencesStatus = "user";
};
ssh.startAgent = false;
- gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
+ gnupg = {
+ dirmngr.enable = true;
+ agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
};
};
@@ -196,12 +199,12 @@
# Testing
ent
- haskellPackages.hopenpgp-tools
# Password generation tools
diceware
dicewareWebApp
pwgen
+ rng-tools
# Might be useful beyond the scope of the guide
cfssl