aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDennis Eriksen <d@ennis.no>2023-11-02 12:44:44 +0100
committerDennis Eriksen <d@ennis.no>2023-11-02 12:44:44 +0100
commit3eddd39a5aa52d40fbc2e0a12b463d270ddfeba2 (patch)
treeb7f4559cf252a32990f5e462dc09b2a9ad23c9b4 /pyproject.toml
parentadd comment about manual starttime (diff)
downloadenergyscripts-3eddd39a5aa52d40fbc2e0a12b463d270ddfeba2.tar.gz
adding linting with ruff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..241d61a
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,54 @@
+[tool.ruff]
+# https://docs.astral.sh/ruff/rules/
+# Enable:
+# Pyflakes (`F`)
+# Pycodestyle (`E`)
+# Whitespace-warnings (`W`)
+# isort (`I`)
+select = ["E", "F", "W", "I"]
+
+# E501 too long lines
+# F403 star-imports
+# F405 undefined functions as a result of star-imports
+# W191 tab indents - `ruff format` recommends this be ignored
+ignore = ["E501", "F403", "F405", "W191"]
+
+# Allow fix for all enabled rules (when `--fix`) is provided.
+fixable = ["ALL"]
+unfixable = []
+
+# Exclude a variety of commonly ignored directories.
+exclude = [
+ ".bzr",
+ ".direnv",
+ ".eggs",
+ ".git",
+ ".git-rewrite",
+ ".hg",
+ ".mypy_cache",
+ ".nox",
+ ".pants.d",
+ ".pytype",
+ ".ruff_cache",
+ ".svn",
+ ".tox",
+ ".venv",
+ "__pypackages__",
+ "_build",
+ "buck-out",
+ "build",
+ "dist",
+ "node_modules",
+ "venv",
+]
+per-file-ignores = {}
+
+# Same as Black.
+line-length = 88
+
+# Allow unused variables when underscore-prefixed.
+dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
+
+# Assume Python 3.10
+target-version = "py310"
+