aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index de2c150..8c3700d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,44 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "energyscripts"
+version = "0.0.1"
+description = "Some pythonscripts to query different energy-APIs"
+readme = "README.md"
+requires-python = ">=3.9"
+
+dependencies = [
+ "DateTime~=5.2",
+ "litequeue~=0.7",
+ "paho-mqtt~=1.6",
+ "psycopg~=3.1",
+ "python-dateutil~=2.8",
+ "requests~=2.31",
+ "tzlocal~=5.2",
+ "urllib3<=2", # urllib3 >v2 warns about not using openssl. See https://github.com/urllib3/urllib3/issues/3020
+ "xmltodict~=0.13",
+]
+
+[project.optional-dependencies]
+dev = [
+ "ruff~=0.1",
+]
+esphome = [ # aioesphome requires "cryptography"
+ "aioesphomeapi~=18.2",
+ "zeroconf~=0.120",
+]
+neohub = [
+ "neohubapi~=1.1",
+]
+
+[project.urls]
+"Homepage" = "https://git.dnns.no/energyscripts/"
+
+[tool.hatch.build.targets.sdist]
+include = []
+
[tool.ruff]
# https://docs.astral.sh/ruff/rules/
# Enable: