aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorDennis Eriksen <d@ennis.no>2023-09-13 22:08:50 +0200
committerDennis Eriksen <d@ennis.no>2023-09-13 22:08:50 +0200
commit74168548c0c96e155e7615f2cb1ae71770ef4713 (patch)
tree2cd99c8a96577906210a35167ee862cbcbf782c9 /rust/Cargo.toml
parentRedid the sh-version. (diff)
downloadmakepass-74168548c0c96e155e7615f2cb1ae71770ef4713.tar.gz
Adding rust-version
This needs a lot of cleanup and commenting, but it works. It's FAST. Even faster than the go-version.
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
new file mode 100644
index 0000000..99ede9d
--- /dev/null
+++ b/rust/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "makepass"
+version = "0.1.0"
+edition = "2021"
+rust-version = "1.68"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+
+rand = "0.8.4"
+clap = { version = "4.3.24", features = ["cargo"] }
+terminal_size = "0.2.6"