aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDennis Eriksen <d@ennis.no>2023-11-02 12:49:02 +0100
committerDennis Eriksen <d@ennis.no>2023-11-02 12:49:02 +0100
commitb322330b000a6d566e99cde1c29429a23b5f2cb3 (patch)
treee6c6b646869e853de4dd9179d5c6f5a5ce5bc153 /pyproject.toml
parentadding linting with ruff (diff)
downloadenergyscripts-b322330b000a6d566e99cde1c29429a23b5f2cb3.tar.gz
adding formatting with ruff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 241d61a..de2c150 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -52,3 +52,15 @@ dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
# Assume Python 3.10
target-version = "py310"
+[tool.ruff.format]
+# Like Black, use double quotes for strings.
+quote-style = "double"
+
+# Like Black, indent with spaces, rather than tabs.
+indent-style = "space"
+
+# Like Black, respect magic trailing commas.
+skip-magic-trailing-comma = false
+
+# Like Black, automatically detect the appropriate line ending.
+line-ending = "auto"